PTL logo

From: Lorenzo Dematté (dematte_at_[hidden])
Date: 2008-06-10 15:40:19


well.. you don't connect two computers with MPI.. a cluster is different
from the classical client/server model.
Anyway.. you should not name the machines and let mpiexec choose for
you. Also, you need to run mpiexec on your headnode (don't think that
the SDK allow you to use multiple machines, but I can be wrong).
Also, check that MSMPI service is running on your headnode AND cluster
nodes.

Regards,
Lorenzo

Qi Zhu wrote:
> Hi,
>
> I am trying to connect another computer to run a MPI.net program.
> The command I am using is:
> C:\Qi\VS2005 projects\MPIHello\bin\Debug>mpiexec -hosts 2 ZWU-XP3G
> WT-QZHU0508 C
> :\Temp\MPIHello.exe
>
> and the error message is:
> mpiexec running on wt-qzhu0508 is unable to connect to msmpi service
> on ZWU-XP3G
> :8677
>
> Other MPI error, error stack:
> MPIDU_Sock_post_connect_filter(1278): unable to connect to ZWU-XP3G on
> port 8677
> , exhausted all endpoints
> MPIDU_Sock_post_connect_filter(1328): unable to connect to ZWU-XP3G on
> port 8677
> , No connection could be made because the target machine actively
> refused it. (
> errno 10061)
>
> Can anybody tell me how can I work it out? Thanks a lot.
>
> --
> Thanks and Regards
> Sincerely Yours
> Jeffrey
> ------------------------------------------------------------------------
>
> _______________________________________________
> mpi.net mailing list
> mpi.net_at_[hidden]
> http://www.osl.iu.edu/mailman/listinfo.cgi/mpi.net
>