PTL logo

From: Davi Morais (misterdmf_at_[hidden])
Date: 2009-12-09 13:05:01


I fixed it, but another error message:
Any suggestions?
Stacktrace:

  at (wrapper managed-to-native) MPI.Unsafe.MPI_Comm_test_inter (int,int&)
<0x00004>
  at (wrapper managed-to-native) MPI.Unsafe.MPI_Comm_test_inter (int,int&)
<0xffffffff>
  at MPI.Communicator.Adopt (int) <0x00035>
  at MPI.Intracommunicator.Adopt (int) <0x00013>
  at MPI.Environment..ctor (string[]&,MPI.Threading) <0x0044e>
  at MPI.Environment..ctor (string[]&) <0x00015>
  at Hello.Main (string[]) <0x0003b>
  at (wrapper runtime-invoke) Hello.runtime_invoke_void_object
(object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

    /usr/bin/cli [0x80c8824]
    /usr/bin/cli [0x80f4693]
    [0xb0c410]
    /usr/lib/libmpi.so(PMPI_Comm_test_inter+0x55) [0x611975]
    [0x126a90]
    [0x1268f6]
    [0x126874]
    [0x12659f]
    [0x126046]
    [0x1212c4]
    [0x121203]
    /usr/bin/cli(mono_runtime_exec_main+0xde) [0x81112ae]
    /usr/bin/cli(mono_runtime_run_main+0x15a) [0x81134da]
    /usr/bin/cli(mono_main+0x1aad) [0x80b19bd]
    /usr/bin/cli [0x805aba5]
    /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x1e2b56]
    /usr/bin/cli [0x805aae1]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
[New Thread 0x91db70 (LWP 5619)]
[New Thread 0x92cb70 (LWP 5618)]
0x00b0c422 in __kernel_vsyscall ()
  3 Thread 0x92cb70 (LWP 5618) 0x00b0c422 in __kernel_vsyscall ()
  2 Thread 0x91db70 (LWP 5619) 0x00b0c422 in __kernel_vsyscall ()
* 1 Thread 0x1106f0 (LWP 5616) 0x00b0c422 in __kernel_vsyscall ()

Thread 3 (Thread 0x92cb70 (LWP 5618)):
#0 0x00b0c422 in __kernel_vsyscall ()
#1 0x00eef466 in nanosleep () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x081a3658 in ?? ()
#3 0x00ee780e in start_thread (arg=0x92cb70) at pthread_create.c:300
#4 0x002987ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0x91db70 (LWP 5619)):
#0 0x00b0c422 in __kernel_vsyscall ()
#1 0x00eedf75 in sem_wait@@GLIBC_2.1 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/sem_wait.S:80
#2 0x0812bb29 in ?? ()
#3 0x0814f96c in ?? ()
#4 0x081bf9f2 in ?? ()
#5 0x081de055 in ?? ()
#6 0x00ee780e in start_thread (arg=0x91db70) at pthread_create.c:300
#7 0x002987ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0x1106f0 (LWP 5616)):
#0 0x00b0c422 in __kernel_vsyscall ()
#1 0x00eeec8b in read () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x080c89be in ?? ()
#3 0x080f4693 in ?? ()
#4 <signal handler called>
#5 0x00611975 in PMPI_Comm_test_inter () from /usr/lib/libmpi.so
#6 0x00126a90 in ?? ()
#7 0x001268f6 in ?? ()
#8 0x00126874 in ?? ()
#9 0x0012659f in ?? ()
#10 0x00126046 in ?? ()
#11 0x001212c4 in ?? ()
#12 0x00121203 in ?? ()
#13 0x081112ae in mono_runtime_exec_main ()
#14 0x081134da in mono_runtime_run_main ()
#15 0x080b19bd in mono_main ()
#16 0x0805aba5 in ?? ()
#17 0x001e2b56 in __libc_start_main (main=0x805ab80, argc=2,
    ubp_av=0xbff0c834, init=0x81e3370, fini=0x81e3360,
    rtld_fini=0xd6cd20 <_dl_fini>, stack_end=0xbff0c82c) at libc-start.c:220
#18 0x0805aae1 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

--------------------------------------------------------------------------
mpiexec noticed that process rank 0 with PID 5616 on node davi-pc exited on
signal 6 (Aborted).
--------------------------------------------------------------------------

2009/12/8 Davi Morais <misterdmf_at_[hidden]>

> The error has changed. Now the following error occurs.
> Any suggestions? I'm running on Linux
>
> Unhandled Exception: System.DllNotFoundException: msmpi.dll
> at (wrapper managed-to-native) MPI.Unsafe:MPI_Initialized (int&)
> at MPI.Environment.get_Initialized () [0x00000] in
> /home/davi/Desktop/mpi.netCedma/MPI/Environment.cs:304
> at MPI.Environment..ctor (System.String[]& args, Threading threading)
> [0x00006] in /home/davi/Desktop/mpi.netCedma/MPI/Environment.cs:162
> at MPI.Environment..ctor (System.String[]& args) [0x00000] in
> /home/davi/Desktop/mpi.netCedma/MPI/Attribute.cs:1
> at Hello.Main (System.String[] args) [0x00000] in
> /home/davi/Desktop/mpi.netCedma/Examples/Hello/Hello.cs:21
>
> 2009/12/7 Davi Morais <misterdmf_at_[hidden]>
>
> When I run: mono Hello.exe or mpirun Hello.exe
>> The following error occurs:
>> Unhandled Exception: System.TypeInitializationException: An exception was
>> thrown by the type initializer for MPI.Unsafe --->
>> System.DllNotFoundException: mpinet
>> at (wrapper managed-to-native) MPI.Unsafe:mpinet_MPI_COMM_WORLD ()
>> at MPI.Unsafe..cctor () [0x00000]
>> --- End of inner exception stack trace ---
>> at MPI.Environment..ctor (System.String[]& args) [0x00000]
>> at Hello.Main (System.String[] args) [0x00000]
>>
>
>