PTL logo

From: Matti Bickel (mabi_at_[hidden])
Date: 2010-02-25 18:25:02


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi folks,

the MPI.NET FAQ states:
> can work with (at least) Open MPI, LAM/MPI, and MPICH2

To me, this doesn't appear to be true.

I've recently worked on http://bugs.gentoo.org/show_bug.cgi?id=281207

It appears Unsafe.pl, which generates CustomUnsafe.cs can't handle (at
least) LAM/MPI-7.1.4. I've given up on it, since it doesn't fully
implement the MPI-2.0 standard which mpi.net seems to expect. In
particular, it expects the presence of MPI_SIGNED_CHAR, which LAM/MPI
doesn't provide in the 7.1.4 version.

Help on the mpich2 issue detailed in the bug would be highly appreciated.

I'm attaching an updated patch for Unsafe.pl to at least get a working
CustomUnsafe.cs. Maybe someone is driven enough to go further.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkuHBs0ACgkQfNMcoUhJ7GzqiQCgkx+YUTFTZclIpUeMVQ9D6Pof
5d4AnjmyQ546VZOPBt+LrCI8h8ys9TFb
=rk5o
-----END PGP SIGNATURE-----