PTL logo

From: Carr, Scott (scottcar_at_[hidden])
Date: 2010-05-21 12:06:55


Matti,

I'm using OpenMPI version: 1.4-4.el5

I applied the patches and got a new (similar) error:

CustomUnsafe.cs(111,31): error CS0283: The type `System.IntPtr' cannot be declared const
CustomUnsafe.cs(116,31): error CS0283: The type `System.IntPtr' cannot be declared const
CustomUnsafe.cs(122,31): error CS0283: The type `System.IntPtr' cannot be declared const
CustomUnsafe.cs(129,35): error CS0283: The type `System.IntPtr' cannot be declared const
CustomUnsafe.cs(135,35): error CS0283: The type `System.IntPtr' cannot be declared const
.
.
.
CustomUnsafe.cs(1844,34): error CS0283: The type `System.IntPtr' cannot be declared const
./Group.cs(330,43): error CS0117: `MPI.Unsafe' does not contain a definition for `MPI_GROUP_EMPTY'
./Group.cs(49,50): error CS0117: `MPI.Unsafe' does not contain a definition for `MPI_GROUP_EMPTY'
make: *** [MPI.dll] Error 1

>Yes, unfortunately Unsafe.pl (which generates CustomUnsafe.cs) is very sensitive to changes in mpi.h.

Based on that, it seems like I need to have the same version of OpenMPI that you were using when you made the patch. If you can tell me which version I will try that.

Thanks for your help,
Scott
________________________________________
From: mpi.net-bounces_at_[hidden] [mpi.net-bounces_at_[hidden]] On Behalf Of Matti Bickel [mabi_at_[hidden]]
Sent: Friday, May 21, 2010 8:54 AM
To: mpi.net_at_[hidden]
Subject: Re: [MPI.NET] MPI.NET make error on Linux

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/21/2010 02:16 PM, Carr, Scott wrote:
> I’m running CentOS Linux with OpenMPI.

Can you say which version of OpenMPI you tried this with?

> autogen.sh and configure seem to be fine but when I try to make it gives
> me the error:

Yes, unfortunately Unsafe.pl (which generates CustomUnsafe.cs) is very
sensitive to changes in mpi.h. I've patched it several times, but don't
have access to upstreams svn, so all the patches go into gentoo's
ebuild, available at
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-cluster/mpi-dotnet/

Best, Matti
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkv2gm4ACgkQfNMcoUhJ7Gy03QCgl3s6HXhJvyZLY+7r2neXiU/l
Lx0AoJ/KbdDDIqsgvf+z5b+HETkvD5ZV
=aI2T
-----END PGP SIGNATURE-----
_______________________________________________
mpi.net mailing list
mpi.net_at_[hidden]
http://www.osl.iu.edu/mailman/listinfo.cgi/mpi.net