OOMPI
Version 1.0.4


OOMPI Home
Overview
Documentation
Software
References
Contacts


OOMPI

OOMPI Version 1.0.4


OOMPI Version 1.0.4 (stable)
Files File names Size MD5 sum (GNU md5sum 1.22)
Source code oompi-1.0.4.tar.gz 233KB 75ae7bdec4d6eb4db078656db4cf7289
oompi-1.0.4.tar.bz2 182KB 809464dbea8322bef3d3b20aabf8941a
Documentation for 1.0.4
Files File names Size MD5 sum (GNU md5sum 1.22)
User's guide oompi.pdf 188KB cf57007804491a99103a8e56f18a9a11
oompi.ps.gz 119KB 3b8325c4695e7d26cb22560a81757963

OOMPI has an open-source license.

The tarfile will extract into an "oompi-1.0.4" subdirectory. The README and INSTALL files provide full details for installation and compilation of OOMPI programs. The HISTORY file provides an abbreviated change log history of the development of OOMPI. OOMPI is implemented as a thin layer directly on top of the MPI-1 C bindings; that is, you need to have MPI installed before you can install OOMPI. A comprehensive test suite it also provided that tests your installation of OOMPI.

OOMPI Version 1.0.4 has been compiled and tested on the systems listed below. It is believed that OOMPI will work with most C++ compilers and MPI implementations, but these are the platforms on which it has been tested. Patches to include support for other systems are welcomed at oompi-devel@osl.iu.edu. OOMPI is an on-going project; we hope to build a large base of platform support in order to widely serve the C++ MPI community. Please send us information about any OS or MPI implementation that you would like to see supported in OOMPI.

NOTE: Because of the extensive testing suite included with OOMPI, several flaws in existing MPI implementations have been found. Be sure to read the README and INSTALL files included in the distribution!


Please direct questions, comments, and feedback to:
oompi-devel@osl.iu.edu